Go to home page
EUIPO
Protect your trade marks and designs in the European Union

Protect your intellectual property in the European Union

Menu

System requirements

  • Hardware

    A computer with internet capability is required. A high-speed broadband connection is recommended.

  • Software

    Applications require one of the following web browsers:

    • Internet Explorer 9 or later
    • Firefox 3 or later
    • Safari 4 or later
    • Chrome 5 or later

    Although the applications might work with earlier versions of the above browsers, there could be compatibility problems, i.e. the graphical interface might not be viewed as intended or some of the functions might not work as intended. It is recommended that you install the latest browser versions.

    Since a technical incident might prevent you from opening electronic communications using Internet Explorer 8, we recommend you to use a more updated version of Internet Explorer or another compatible browser: Firefox, Google Chrome.

    Please be aware also that your personal security settings and PC compatibility might impact on functioning and block some content or features.

Page last updated 24-02-2018
We use cookies on our website to support technical features that enhance your user experience. We also use analytics. Click for more information